0 0
Sign in to rate

Vocabulary Unsuspender

<10kB. Updated 2019-05-09. Only supports Anki 2.0.x.

Description

Checks to see what Hanzi are mature from one deck (21+ day interval by default), and unsuspends vocabulary that consists of only your mature hanzi from your vocabulary deck. This add-on is useful for people who are learning individual Hanzi with one deck, and are also studying vocabulary with another deck. For example, you might be using two unrelated decks like: 1) Remembering the Hanzi deck: https://ankiweb.net/shared/info/1627669267 2) An HSK vocab deck: https://ankiweb.net/shared/info/1907668496 Instead of learning random vocabulary alongside random hanzi, this add-on will allow you to first get a grasp of Hanzi, and then expose you to vocabulary using the Hanzi you are comfortable with. Instructions 1) Install the add-on 2) Restart Anki and ensure that all or some of your vocabulary cards have been suspended. Note: Suspending all of your vocab cards and then continuing will result in the suspension all vocab cards that you might have already been studying if they contain non-mature hanzi. 3) Click Vocab Unsuspender under Tools . If it is your first time running this add-on, you will be prompted to select your Hanzi Deck and the Field containing each individual Hanzi as well as the Vocab Deck and the field containing the vocab term. A configuration csv file will be written to the add-on folder to keep track of your choices. If this is not your first time, the configuration file will be read to remember your previous choices, and desired vocabulary will be unsuspended if you have matured any hanzi. 4) If you want to start over or change your selcted decks and fields, you will have to navigate to the vocab_unsuspender add-on folder, and delete the config file there. This will not suspend any cards. Restarting Anki will allow you to use the add-on like its the first time. 5) If you want to change the threshold of a "mature card", you can open the py file, and navigate to line 75. By default, Anki considers cards with an interval of 21 days or greater to be mature, but you can set this to be greater or smaller depending on how comfortable you want to be with the Hanzi before seeing related vocabulary. This is my first Anki add-on, so please let me know if there are any bugs and I'll try to correct them!

Download

This add-on only supports Anki 2.0 - it will not work with recent Anki versions.

As add-ons are programs downloaded from the internet, they are potentially malicious. You should only download add-ons you trust.

To download this add-on, please copy and paste the following code into the desktop program:

1974655937

If you were linked to this page from the internet, please open Anki on your computer, go to the Tools menu and then Add-ons>Browse & Install to paste in the code.

Other Anki 2.0.x Add-Ons Ask a Question