61 20
Contact Author Sign in to rate

(Legacy) Customize Sidebar

<10kB. Updated 2020-01-16.
The author has shared 1 other item(s).

Description

The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete. it doesn't work with the latest version, neither with v2.1.42, nor with v2.1.43 ... v2.1.123 etc !!! With this addon you can customize the sidebar of the browser: 1) Expand/Collapse note types 2) Expand/Collapse decks 3) Expand/Collapse filters 4) Show/Hide 'Marked' 5) Show/Hide 'Suspended' 6) Show/Hide 'Leech' 7) Show/Hide 'Flags' 8) Show/Hide 'Today' WARNING: To collapse/Expand tags please use the 'Hierarchical Tags 2' addon. Configuration options can be found in preferences. Problems, Bugs, Errors, Improvements: github ChangeLog: v2.0.0: Ported to Anki v2.1.17 (15/01/2020) v1.2.0: Today items were added (30/11/2019) v1.1.0: Flags were added (30/08/2019) v1.0.0: Init version (30/12/2018)

Download

As add-ons are programs downloaded from the internet, they are potentially malicious. You should only download add-ons you trust.

Supported Anki versions:

To download this add-on, please copy and paste the following code into Anki 2.1:

1988760596

If you were linked to this page from the internet, please open Anki on your computer, go to the Tools menu and then Add-ons>Browse & Install to paste in the code.

All Anki 2.1.x Add-Ons Contact Author

Reviews

on 1659402250
Doesn't work
on 1658455876
cant use ..
on 1658329900
Does not work with latest Anki version
on 1655900963
can't install :(
on 1648393232
gave an error
on 1642064004
i can't use this
on 1637551751
Thank you,
I downgrade to Anki 2.1.40 from Anki 2.1.43 because any addon doesn't support it,
and this addon works very well,
I feel that I'm using sidebar Anki 2.1.43!

This addon has embedded in Anki 2.1.41 up.
This addon has embedded in Anki 2.1.41 up.
This addon has embedded in Anki 2.1.41 up.
This addon has embedded in Anki 2.1.41 up.
This addon has embedded in Anki 2.1.41 up.
on 1636559071
Guys, don't be dumb )) It's Legacy, as it's implemented into the actual Anki itself now. No use downloading it, you already have it!
on 1634131780
Doesn't work. Won't download at all
on 1633838308
This doesn't work on latest version
on 1631622571
Very useful!!
on 1628607974
This add-on doesn't work in last version
Is there any other add-on similar to this one?
on 1628549557
doesnt support latest version
on 1628533464
No longer works
on 1628389687
does not work
on 1628054854
doesnt work
on 1627852884
The add-on doesn't work.
on 1625868965
It doesn't work
on 1625121965
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
on 1624579325
Thank bro
on 1620408900
awesome
on 1620169620
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!
The functionality of this addon has been implemented in Anki v2.1.41. The addon is obsolete !!!

It works fines below 2.1.40
if you are on .41+ delete the add-on simple as that, don't downvote because of it
on 1619913570
Doesn't work with most current Anki
on 1618522203
Im currently using 2.1.40 on Mac and works excellent! I'm just waiting for the next stable version to update, until now, imma just stay here. Thanks a bunch!
on 1617702330
There was an error and I could use this add on, I am using the latest version.
on 1616599309
*Update*

Thanks to the author for increasing compatibility

Used this add on for over a year, and it was a game changer being able to have flags in the sidebar.
Not looking to update Anki (currently on 2.1.21), so quite sad that as of today (13th March 2021) I can no longer use this add on - just suddenly stopped working.

It was good while it lasted.
on 1615942038
You can get this to work for Anki 2.1.35 by going to the meta.json file and deleting the following line:
"mod": 1579122093, "min_point_version": 39, "max_point_version": 40,
on 1615922758
Removing support from 2.1.35 after it had been working just fine is ridiculous. I cannot update to 2.1.39, as many others cannot, because it breaks other add-ons that have not been updated.

If someone can fork this to 2.1.35, that would be great.
on 1615920340
The addon is really great but I can't use it anymore because I use 2.1.35, if I update, many addons will break; I would like to know if we could access a previous version of this addon, please :(
on 1615767041
Great add-on but stopped working out of the blue yesterday. I really hope it gets fixed ASAP because I really use the heck out of the "added today" tab.
on 1615689573
For those reporting the add on broken, maybe you need to update your Anki, 2.1.42 was recently released.
on 1615686442
Seems many people are having issues with this on older versions so I uploaded a version that should work: https://www.ankipalace.com/downloadable-content
on 1615668213
Stopped working for me randomly today on 2.1.35 and I did not update anything. I cannot upgrade to 2.1.39+ bc of other add-ons that will break. Really wish this stayed working on 2.1.35 like it has been for months.
on 1615646929
Randomly stopped working today, hope this can be fixed asap
on 1615625453
It's a great add on but just randomly stopped working without ever prompting for an update. I can't update beyond 2.1.35 so I guess I just don't get to use this anymore. I would have preferred to stay on the old version of the add on so this is really frustrating that it can update without the users permission.
on 1615625013
It was a good addon but unfortunately as the highest version I can use is 2.1.35, it stopped working. I hope there will be an 2.1.39 update for Anki on MacOS 10.12.
on 1612785874
Very helpful!
on 1611152912
good!
on 1609464806
Great addon!!
on 1605340118
Must have !

'Added Today' — that's what I need all the time; so is it possible to add

"collapse_today": false,

?
on 1603445011
easy and VERY useful. works well on Version 2.1.36
on 1601637317
Very convenient. Love it.

How to set up custom filter (reiterating what the author said):
1. Open card browser and enter the filter combination you want to save
2. Open "Go" tab (or just select the "Filter" button to the left of the search line where you put your filters)
3. Select "Filter"
4. Choose option "Save current filter" and name it.
5. Access your custom filters at "My Filters on the left"
on 1599383958
Useful add-on
on 1598738958
This awesome app fixed my OCD
on 1598652999
Works very good!!
on 1597072923
Uhhg THANK YOU !!!
on 1596486227
Awesome! Absolutely necessary
on 1596379608
Great add on!
on 1595126317
Great!
on 1594737813
ok!
on 1591355168
Thank you!
on 1590377528
Really great, my sidebar is so clean now! How do I use the "My Filters" function? I checked in Preferences but didn't find it.
Comment from author
To use custom filters you should create one by selecting the menu item "Save current filter ..." under the "Filter..." button on the sidebar panel and after that saved filter appears in the tree. I noticed saving function is broken in the anki v2.1.25 (I tested it) and fixed in the v2.1.26. So please update your anki on the latest version. And yes, I didn't add an option for filters in the preferences. I will add it to the next addon release.
on 1590235241
Essential
on 1589462162
best addon for organizing
on 1588309883
Very useful
on 1587090302
my side bar is more clean now! thank you!
on 1586044677
absolutely essential, should be a native feature
on 1582225115
10/10
on 1581376025
Good!
on 1580539491
Essential!!!
on 1580226466
Simple and elegant. Also really wish this was part of original Anki.
on 1579358180
great add-on.
thank you.
on 1579169921
Tanks
on 1578134485
awesome
on 1576716975
thank you so much, lots of love from India! <3
on 1576706095
thank you
on 1575735913
Should be part of the release version.
on 1575150100
Great functionality and time saving
on 1575149124
Thank
on 1575142932
Excellent new additions and the update was pushed without ruining previous preferences, thank you!
on 1571466591
This tool is effective!
on 1568960567
Love it. Really convenient. Now I don't freak out anymore every time I open my Anki browser. Thanks a lot!
on 1565211567
time-saver
on 1563794092
Thank you! It's great not to have to expand the decks manually any more!
on 1558523385
good
on 1556690735
Nice
on 1554404261
please add some kind of functionality to expand/COLLAPSE the tags in the side bar... I've got 30,000 med school cards and the side bar scrolls FOREVER with all of the tags used!! Otherwise very helpful.
Comment from author
To expand/collapse the tags you may use the 'Hierarchical Tags Addon (2.0 => 2.1)'
on 1552923554
FANTASTIC! Really makes the sidebar so much cleaner!
on 1549906315
I have been finding such a plugin for a long time. It's you. Thank you!
on 1549463756
Ace! More complete addon than similar ones
on 1548997357
nice!
thank you~